Loading...
Security Resources

Software Updates

TrustKeeper Scan Engine Update for August 3, 2023

Summary

The latest update to the TrustKeeper scan engine that powers our Trustwave Vulnerability Management product (including both internal and external vulnerability scanning) is now available. Enjoy!


New Vulnerability Test Highlights

Some of the more interesting vulnerability tests we added recently are as follows:

Amazon Linux (Credentialed Checks)

Debian (Credentialed Checks)

Drupal

  • Drupal Core API Access Bypass Vulnerability (SA-CORE-2022-009) (CVE-2022-25274)
  • Drupal Core File Download Access Bypass Vulnerability (SA-CORE-2023-005) (CVE-2023-31250)
  • Drupal Core File Upload PHP Code Execution Vulnerability (SA-CORE-2022-014) (CVE-2022-25277)
  • Drupal Core Form API Access Bypass Vulnerability (SA-CORE-2022-013) (CVE-2022-25278)
  • Drupal Core Form API Improper Input Validation Vulnerability (SA-CORE-2022-008) (CVE-2022-25273)
  • Drupal Core Image Module Information Disclosure Vulnerability (SA-CORE-2022-012) (CVE-2022-25275)
  • Drupal Core oEmbed Improper Input Validation Vulnerability (SA-CORE-2022-015) (CVE-2022-25276)

Fedora (Credentialed Checks)

FreeBSD

Microsoft

Red Hat (Credentialed Checks)

Samba

Splunk

Suse (Credentialed Checks)

Ubuntu (Credentialed Checks)

How to Update?

All Trustwave customers using the TrustKeeper Scan Engine receive the updates automatically as soon as an update is available. No action is required.